BETA CAE Systems USA, Inc.
login Search
headers_SUPPORT.jpg
FAQs

General Questions



 We have an industry leading pre-processor called ANSA and a post processor called µetaPost. Through these tools we support many standard solvers for structures and CFD analysis. BETA CAE does not develop or distribute any solvers. 
 The user guides and tutorials are available in installation directory in the “docs” folder. You can refer to the “Documentation” section on Support page for more literature. For any further
 Trainings are regularly offered for various levels of users. Please refer to the “Training” section for schedule and registration.
For any support questions please contacts at our hot line. The number is 1 248 737 9760 ext 5. Our support specialists are available from 9 to 5 EST. You can also send us your questions and feedback to This e-mail address is being protected from spambots. You need JavaScript enabled to view it
 Evaluation licenses are provided to the organizations that want to try the BETA CAE Products. Please contacts This e-mail address is being protected from spambots. You need JavaScript enabled to view it . You can also call our support hot line for more details. 
 Yes. ANSA supports both 32bit and 64bit operating systems. If the memory in the machine exceeds 3 GB, then there are benefits in using the 64bit version of ANSA as it will allow the manipulation of models larger than 32bit systems.
 If you are a current customer and already have a license purchased from Beta CAE Systems, You can download the latest version from our FTP site.
ANSA and µETA comes as one package. If you own an ANSA license, you have full access to µETA. 



ANSA



Starting with v13.0.1, ANSA and µetaPOST store the defaults settings file in a hidden directory called '.BETA' which is located in your home directory. 
If the ANSA window appears 'then' disappears, it is most likely an issue with the license server. Please check the environment variables of the system or in the application launch file to make sure the license server is specified. If it is specified, check to make sure the license server is running. You can 'ping' the machine from command prompt. If the license server is running, then check to make sure there are enough credits to start ANSA. It might help to start ANSA from the command prompt to see what message the application printed before disappearing. If everything looks correct, please contact your local customer support agent. 
No. The ANSA database is only forwards compatible. This means that you can open an ANSA database in a later version of ANSA, but not an earlier version. In such situations, you can write out a keyword file and import it back into the old version of ANSA. 
The translation of CAD data is performed outside of the main ANSA application. There is a separate application called the "ansa_transl_gui" which will run the respective CAD translator in the background (i.e. CATIA, UG NX, Pro/Engineer, and JT). This application needs to be installed and the respective license is required to run the CAD translators. Once the data is translated, ANSA will then open the file (or merge if multiple databases) into an ANSA session. 
ANSA: Automated Net Generation for Structural Analysis. 
* Cross Section Analysis Tool
* Volume Traps
* Fuel Tank 
* GUI settings are saved in "ANSA.xml" file
* Application settings could be stored in "ANSA.defaults" file. 
ANSA.defaults file could be found under “config” directory of ANSA installation directory. Also, user specific ANSA.defaults files can be saved in the home directory or the working directory of the user. Below is the order in which ANSA reads the defaults file: -Firstly, the ANSA.defaults file located in the ANSA_HOME directory is read. - Secondly, the ANSA.defaults file located in the user's home directory in .BETA folder. - Finally, ANSA reads in the ANSA.defaults file located in the current working directory 
The "Start In" directory of the ANSA executable should be pointed towards the Work directory in windows platform. 
User can automate or run ANSA in batch process by:
(a) Using the ANSA Scripting Language
(b) Using SESSION FILES 
The availability and usage of BETA CAE Tools could be checked by running the "beta_lm_stat -h server_name" command. 
Provide the material database path in the ANSA.defaults as "NAS_MAT_DBASE =, DYN_MAT_DBASE =, PAM_MAT_DBASE =, ABQ_MAT_DBASE=, RDS_MAT_DBASE =, ANS_MAT_DBASE =, MAD_MAT_DBASE =" for ANSA supported decks. 
User defined functions could be stored/saved in ANSA_TRANSL file. ANSA will automatically execute the user defined functions from ANSA_TRANSL file. Refer to ANSA Scripting user guide for more information on ANSA_TRANSL. 
ANSA Data Management is a centralized data management system, used to collect and store in a structured and hierarchical form all engineering data that is used during the development process of a vehicle simulation model. The engineering data can be Parts and subassembly data, Analysis models, Sub-systems, Processes, Library Items, Post processing data and Test results. The user can specify one or more Data Management root directories using the Set DM Root Functionality. With one click a DM can be set as the Current DM. 
Compare from File, is a functionality of the Parts Manager that compares parts or groups of a working ANSA db. with a new ANSA db that resides in the file system. The comparison is done for Properties, Materials and Geometry. The function is accessible through the parts manager. 
In order to replace a part/group, the user can access the Replace functionality available through the parts manager (right mouse click on a part/group). During replacement, ANSA will take into account the existence of Connection Points or Bolts affecting the incoming/outgoing parts, the existence of shell elements assigned to a NULL material, entities participating in SETs, the existence of SEGMENTS, and the existence of Pasted Nodes connecting the outgoing sub-assembly with the remainder of the assembly. For a more in-depth look at the Replace functionality, please refer to the user’s guideline. 
The Fill HOLE function (TOPO>CONS>FILL HOLE) fills holes on Faces. The holes can be of any shape. The holes can be selected manually or automatically among the visible ones if they fall below a user specified diameter. There is an option to create automatically 3D Curves, Points or Connection Points of the removed holes, to mark their shape and position for future reference. 
Plane Cut functionality (MESH>SHELL MESH>UTIL>PLANE CUT) can be used to achieve this result. This function creates cutting planes to cut along meshed macros or FE mesh and reconstructs the mesh considering the new edges along the cut. The reconstruction takes place as per the defined Mesh Parameters and Mesh Criteria (F11). After reconstruction the selected elements will be split 
There is no UNDO button as such. But some of the functions got a reverse function to retrieve back old information. Most instances could be easily redone. It’s a good practice to SAVE your work at regular intervals. 
External weld file formats like VIP, VIP (CSV), XML, and VIP2 can be read into ANSA directly. 
All UNUSED grid points, coordinate systems, properties, materials, sets and other information that are defined but not used in the model could be suppressed using MENUBAR>File>Compress. 
A. In any of the list windows you open, you can click on the small downward pointing arrow icon on the right to pick from the pull down list or type the field name as it appears in the card to add that information as a column in the list. 
A. You can press the Pause/Break key or the Esc key to interrupt the operation. 
An image can be created from the visible working area using MENUBAR>File>Print to file.  The following output formats are currently supported: POSTSCRIPT, RGB, TIFF, JPEG, PNG or BMP. 
If you are in the TOPO module and have the visibility in ENT mode, you will see all the faces appear in either GREY or YELLOW. GREY is the positive side and YELLOW is the negative side. You can use TOPO>FACEs>INVERT to invert the normal. TOPO>FACEs>ORIENT could be used to orient the normal of different faces in one direction. 
Click on TOPO>HOTPOINTS>PROJECT/MULT. PROJECT function; select the point(s) to be projected. Then select the surface by clicking on its CROSS HATCH (green dotted lines). This will create a weld spot on the surface, indicated by purple cross in TOPO menu and red solid point in MESH menu, which when meshed will contain a node at the weld spot. 
Set quality criteria under SOLIDS tab in the Quality Criteria window (F11). Click on FOCUS>EXTREME to isolate the quality violating elements. Click on FOCUS>NEIGHB>1st level couple of times to display the neighboring elements. Set relatively strict quality threshold values under MESH>VOLUMES>PARAM function. Click on MESH>VOLUMES>RECONS button, select the visible tetra elements and middle click. This will reconstruct the tetra elements and improve their quality automatically. 
The reasons for unmeshed MACROs can be several. Check for unchecked faces (Unshaded faces) using FOCUS>Unchecked. If there are any, fix corresponding geometry issues. Sometimes the resolution of the edges might be such that they might cross over each other. In such cases, improve the resolution by lowering the mesh length on the perimeters (use MESH>PERIMETERS/MACROS>LENGTH) or increasing the number of nodes on the perimeters (use MESH>PERIMETERS>NUMBER). 
Yes, ANSA's morphing tool can be used to model shape changes to an existing design to create new Design Variations. The existing design can be a Geometry model or a complete FEA/CFD mesh model with analysis specific information. The shape change steps can be parameterized and simulated through an Optimization Task in ANSA. For extreme shape changes, the quality of the mesh can be automatically fixed in regions of high mesh deformation using ANSA's mesh reconstruction tools. 
Yes, the shape change parameters in the Morphing module can be accessed and modified externally by Optimization software through a Design Variables file. This ANSA setup can be driven and run in batch mode (with no GUI option) iteratively by Optimization software for D.O.E. and Optimization studies. 



µETA



NASTRAN, LS-DYNA, ABAQUS Standard, ABAQUS Explicit, PAM-CRASH, RADIOSS, Madymo, ANSYS, Medina, and PATRAN.
NASTRAN, LS-DYNA, ABAQUS Standard, ABAQUS Explicit, PAM-CRASH, RADIOSS, Madymo, ANSYS, Medina, and PATRAN.
Within the animation control panel, by left clicking on the red button you will get the option to record all changes of the Active Window and produce an avi, gif or mpeg2 video. Also the user can control the frames-per-second (fps) of the recorded video file by applying the command (for an avi video): record avi fps (frame rate)
From the Save option under the File pull-down menu, the Export to File card can be invoked. Use this card in order to output the Node coordinates and element connectivity, corresponding to the current state of the Active Model, in a NASTRAN Bulk file format (ASCII format).
The explode command and its associated options can be found in the commands window. Explode auto takes place relatively to a point which is user defined whereas explode center is performed relatively to the center of the model. Coordinates of the center and the scale factor should be separated with commas.
µETA has capability to automate the frequently performed actions. There are two ways to automate µETA:a. Session files (also referred to as sessions)b. ScriptsThe user can utilize both tools simultaneously, since a session file can include a script section while a script, on the other hand, can call the execution of a session file.
Using the Follow Node feature active (one or more points) under the Tools>Visual>Views Management> will achieve this. The model will be viewed deformed but relative to the selected nodes.
One or more cut planes may be applied on models, in order for the user to acquire a better view of the interior of a model or to view results on the resulting cut section. Cut plane functions are regulated from Cut Planes card, but some functions also appear within the main interface for fast application.
Switch the identify toggle button to the iNode or iElem option.Select nodes from the screen.Nodes/Elements are identified and their id and results for the current state appear in the µETA-Post messages window and on the screen. For more information please refer to µeta-Post Users Guide.
Yes. The user has the option to create multiple Drawing (3d) windows and 2d plot windows. Loaded models appear in all 3d windows that exist at the time of loading. 2d plot windows are used to view results in a 2-D diagram form.In order to create a 3d or 2d window, select with the left mouse button the corresponding option from the Windows pull-down menu.For a more in-depth look at all available functionalities of µETA-Post, please refer to the µeta-Post Users Guide.
In order to set the Fringe drawing style, activate the Fringe flag button from the Drawing styles group of flag buttons.The color bar appears implying that the view is in Fringe mode. Press the Fringe flag button (middle or right mouse button).From the Fringe Options card that appears, the user can select the Fringe Colors and also many other available options.
Within the animation control panel, there is the option to record all changes of the Active Window and produce an avi, gif or mpeg2 video. Note that the user can control the frames-per-second (fps) of the recorded video file by applying the command (for an avi video): record avi fps
You can have it turned off by accessing TOOLS>SETTINGS and navigate into Windows Settings and have the "Show title” option unchecked.



CAD Translators



File that can be translated into ANSA format include CATIA, Unigraphics, ProE and JT type Cad files.
 
Yes. The user has the option to save the translation result in a different directory, other than the one where the original CAD file was read from.
ANSA_TRANSL is an ASCII file which can contain ANSA script commands that can be executed during the translation process. The script commands can perform certain specific tasks such as extraction of attribute information defined in the CAD system, definition of the extracted attributes in ANSA file, inspection of the quality of translation and other customizable tasks.
Yes, the hierarchy information as defined in the assembly file can be extracted and populated in the ANSA database under Parts Manager section. This hierarchy information contains all the important information such as Part Name, Part Number, Version Number, Position Matrix information etc.,.
No. CAD files written out in neutral format such as IGES, VDA-FS and STEP can be directly read into ANSA.
CAD files prepared in native formats can also be exported in one of the neutral formats such as IGES, VDA-FS and STEP, and imported into ANSA. However, the usage of ANSA Translators to translate the native CAD format files offers better interpretation of CAD topology, as defined using the CAD system. This would result in an ANSA model that contains fewer geometry issues compared to the one obtained by importing the corresponding neutral CAD file.
If the machine has a local installation of UG, make sure the environment variables, UGII_BASE_DIR, UGII_ROOT_DIR, UGS_LICENSE_SERVER are defined. This can be checked by typing SET command in the command window. In addition, make sure ansa_ug.bat (for Windows) or ansa_ug.sh (for UNIX) file exists in the ANSA installation directory and points to ansa_ug3.exe/ansa_ug4.exe/ansa_ug5.exe depending on the version of the UG installation.
 
Frequently Asked Questions